tk-3dsmax Documentation
Setup and Configuration

tk-3dsmax Documentation

This engine connects Tank and 3D studio Max. Tank will appear as a floating menu bar and will place itself in down the bottom of the UI layout at startup.

Engine

In order to use Tank with 3dsmax, you need to have the 3dsmax blur python extensions installed. You can find them here: http://code.google.com/p/blur-dev/wiki/Py3dsMax. The Tank Engine currently supports versions 2012 and 2011 of 3dsmax.

SSL Python Heap Walk Bug

If Python is running slowly in 3dsmax or if you notice a pause when 3dsmax starts, this is likely to be because of a bug in the SSL libraries that ship with python. This bug only affects applications which have a significant memory footprint and is therefore not noticable most of the time. However, with something like 3dsmax it may be a problem.

The solution is to replace the python ssl library with a patched version that contains an upgraded version of the ssl backend library. You can find the _ssl.pyd file here:

Engine

And here is a replacement file to use for Python 2.6: _ssl.pyd

Make sure to make a backup copy of your existing file before making any changes to your system!

Setup and Configuration

To see all the various configuration parameters that you can set in order to customize the behaviour of this item, please head over to the settings page.

tk-3dsmax Documentation. This was auto generated on 2013-04-24. Click here for Release Notes.